Monday, September 24, 2012

Setup previously failed while performing the action "BuildToBuildUpgrade". You cannot resume setup by performing the action "Uninstall".

Recently I’ve encountered an issue while phasing-out Exchange 2007 SCC Mailbox Servers after an upgrade to Exchange 2010
 
Symptoms:

1-      Uninstallation failed as per the below screen shot.
 

2-      Even ID 1002 is logged in the even viewer with the error “Setup previously failed while performing the action "BuildToBuildUpgrade".  You cannot resume setup by performing the action "Uninstall".”
 


Cause:

                Exchange keeps tracks of failed through a registry key called “watermarks” so it can continue where it left over in case of setup failure more info can be found here,

                The same key is the cause of this issue as sometimes the setup succeed where the key is saying it failed

Resolution:

You will need to open the regedit and browse to the following location “HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\ClusteredMailboxServer”
 

Delete the Action and Watermark keys
Now retry the uninstallation and see the magic


see you soon, Hany Donia

3 comments:

charlesgate86 said...

It reminded me one of my scheduled upgrade activity of Exchange 2007 SP1 - SP3 with SCC configured for one of my client long time back.

One of the last issue what i faced you mentioned in above article - cool...!

http://charlesgate86.wordpress.com/2012/02/28/installing-exchange-2007-sp3-issue-tracker/

Joshua Ritchie said...

Thanks!
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ExchangeServer\v14\PreFileCopy]
Exported Key, then Removed: "Action" & "Watermark"

pramod Reddy said...

thanx a lot....